TCS CS-105

Discussion in 'Other DCC systems' started by dwoomer, Oct 26, 2023.

  1. dwoomer

    dwoomer Member

    Have any of my fellow Frisco modelers bought the new DCC system from TCS with wireless throttles? What was been your experience with it? My 20 year old NCE ProCab system died first week of September, NCE said it wasn't worth fixing. So I bought the CS-105 and the UWT-50 wireless throttle ($750 worth). It worked for 24 hours and then went haywire. Some locos would work fine, others not at all, still others had full light control but no motor, and one had no motor but a continuously flickering headlight. I can tell you that TCS customer service is not the greatest - I would email them and wait a week or more for a response. They would give me some tests to run, which I did, and sent the results back. Another week or more till the next email. After 2 months of this, they finally said they didn't know what was going on, and to send it back, which I did.
    Then I dug the NCE command station out of the trash to see if I could get the programming track up and working to check my loco decoders. After a few hours of fussin' and cussin', I got it up and able to program. I looked at the locos that wouldn't run, and the results weren't pretty - blown decoders, including one QSI sound loco. Thank God I only had 8 of my locos on the layout at the time. All had run fine previously on the NCE command station. I still haven't heard from TCS. Would like to find out why it blew my decoders (I wasn't even programming with it yet!). I have done online searches and found some mention of faulty programming in the command station, but not being a digital guru I could not understand it all.

    CAUTION if you're thinking about this command station, wait until they get the bugs worked out!
  2. pbender

    pbender Member Supporter

    I have not had any issues with mine.

    I also had a pre-release beta system for a while, and it also worked fine.

  3. dwoomer

    dwoomer Member

    I just got a message from TCS, the first layer of techs could not diagnose it and they had to send it to the engineers. A faulty wifi chip was causing the problems. It took an extraordinary amount of time to connect (even though the throttle said it was connected), and the communication between the throttle and command station was significantly prolonged. Additionally, it would shut off at various times for no apparent reason. They are sending me a new command station, hopefully my problems will be solved.
    Ozarktraveler likes this.

Share This Page